Dell Server onboard networking gotcha’s

By Robert Dick today…


I had real fun with a DELL R300 server after a motherboard replacement.  Learned bunches but first a little background.


What originally went wrong?


The Dell R300 lost” the MAC addresses on the twin onboard NIC’s and we couldn’t get them back.  ESXi lost its networking because of this — no MAC, no link layer, no network.  Dell support did not suggest anything at this point other than a motherboard replacement.  BTW, we went through a similar issue with another T300 server.


So, they sent a new motherboard.  Problem solved, right?


No, me buckos, problem not solved.  The motherboard we received was refurbished running the same rev BIOS as the original board.  As a matter of course I updated the BIOS to newest rev (same as our R300) and went about getting the box ready for ESXi4.  I noticed that the BIOS had “Virtualization” turned off so I turned it on (needed to support ESXi).  Boom!  MAC addresses gone!


OK, then what?


Went around in many circles.  By setting the onboard NVRAM_CLR jumper I could clear BIOS settings and get the MAC addresses back but soon as virtualization turned on the MAC’s went out the door.


Interesting.  OK, you had less hair at this point, what did you do?


Got to Level3 tech support at Dell and after a whole bunch of chatter it was suggested that we update NIC firmware with a release that just came out.  Fine and dandy but the PROCESS to update the firmware was more than a little interesting.  Dell, unlike HP, does not have a clear and easy strategy to update firmware in a machine.  HP has a bundled firmware update system that is as simple as booting a CD, select firmware update and ALL updateable firmware in the machine is updated.  Dell makes you update each item individually and if the machine is NOT already running Windows it becomes a real challenge.  Dell supplies a utility, OMSA, that is Linux based that lets you run diagnostics and update firmware and such.  Only problem is updates MUST be done at command line and if you are not Linux savvy it becomes something of a nightmare.  However, once I figured it out the update applied and everything is now good with the box.




Always try firmware updates!